Check Add-on Compatibility Before Updating to Firefox Releases

I usually download a new version of Firefox as soon as its available, but have gotten "burned" because many extensions & add-ons I use aren't immediately compatible -- developers usually need a couple of days to update an add-on to work with the latest version of Firefox.

Now that I've installed the Is It Compatible? add-on, I can see at a glance which extensions will work with any version of Firefox. Checking the Add-ons Manager I can see there's a new bit of data added to each entry (3.0 - 3.7a); you can easily see what versions of Firefox each extension is compatible with.

Download it here: https://addons.mozilla.org/en-US/firefox/addon/66590

Topic: